Module talk:Effective protection level

Jump to navigation Jump to search

Pending changes

@Jackmcbarn: As part of my work on a {{pp-meta}} replacement I need a function to detect the pending change level of a page. And I thought that this module would be as good a place to put that function as any. I've had a go at adapting the module in the sandbox - let me know what you think. — Mr. Stradivarius ♪ talk ♪ 00:51, 26 March 2014 (UTC)

@Mr. Stradivarius: I've made some adjustments to it. How is it now? Jackmcbarn (talk) 21:19, 27 March 2014 (UTC)
Looks good, thanks for making the changes. Putting pending changes detection in the main function does seem easier. Also, I didn't know pending changes could be activated on a page but not be limited to reviewing by autoconfirmed or reviewer users. You learn something new every day. :) — Mr. Stradivarius ♪ talk ♪ 02:47, 28 March 2014 (UTC)
Well technically, that's one of those things that the software can do but isn't set up to work here on enwp. Anyway, I'm adding it to the live version then. Jackmcbarn (talk) 01:06, 30 March 2014 (UTC)

JSON

@Jackmcbarn: It looks like we need to add .json user pages to this module judging from this week's tech news. The protection doesn't appear to be in force yet, though. I think this edit should do the trick - do you see any issues with it? Best — Mr. Stradivarius ♪ talk ♪ 11:35, 3 April 2018 (UTC)

I went ahead and made the edit. — Mr. Stradivarius ♪ talk ♪ 11:55, 6 April 2018 (UTC)
The article is a derivative under the Creative Commons Attribution-ShareAlike License. A link to the original article can be found here and attribution parties here. By using this site, you agree to the Terms of Use. Gpedia Ⓡ is a registered trademark of the Cyberajah Pty Ltd.